Troubleshooting MR Access Point Client Roaming Issues
Overview
In wireless deployments, clients roam between access points (APs) as part of standard operation. Clients may not dissociate gracefully when roaming, or roaming can cause disruption on certain configurations.
This article explains how Meraki MR access points manage client roaming and how to troubleshoot two related roaming issues:
-
Magic ARP: APs use this mechanism to keep client association tables consistent
-
Fast Reconnect: fix roaming issues for APs on 802.1X-enabled SSIDs
Environment
-
Wireless network with multiple APs
-
Microsoft (MS) Server managing 802.1X authentication (for the 802.1X roaming issue)
Troubleshooting Magic ARP verification issue
If a client did not dissociate gracefully when roaming, then two or more APs may believe they have the same client associated to them. Meraki APs use a "Magic ARP" to inform other APs that a client has associated.
Possible causes
-
Client is out of range of the original AP
-
Wireless card reset
-
Multiple access points reply to the same client, causing connectivity problems
Troubleshooting steps
Contact Meraki Support for further troubleshooting.
Expected behavior
- The log line confirms the AP sent an ARP probe with the client's spoofed MAC (sha) and a 6.x.x.x target IP address (tpa), confirming the captured ARP is a Magic ARP.
- When a client associates to an MR AP, that AP crafts an ARP frame spoofing the client's MAC with a 6.x.x.x IP address to uniquely identify the AP sending the ARP. The spoofed client MAC denotes which client other APs should drop from their association table if they still show the client as associated. The AP sends the Magic ARP as a broadcast both wirelessly and over the wire for the highest probability of reaching other MR APs in the network.
Troubleshooting 802.1X roaming connectivity issue
Roaming between APs causes the wireless connection on an 802.1X-enabled SSID to disconnect. This may require a manual reconnect on the client machine. This solution applies only to customers using a MS Server to manage their 802.1X authentication.
Possible causes
-
The 802.1X session does not resume after the client roams to a new AP, forcing a full reauthentication that drops the connection.
Troubleshooting steps
-
On MS Server, open the PEAP settings for your wireless network policy.
-
Select the Enable Fast Reconnect option under the PEAP settings.
Expected outcome
Roaming between APs no longer disconnects the wireless connection on the 802.1X-enabled SSID. PEAP fast reconnect reduces response time since clients do not need to reauthenticate each time they associate with a new AP.

