Skip to main content
Cisco Meraki

Meraki Go App - Mobile Device Requirements

The Meraki Go app currently support both Android and iOS devices. In addtion to a compatible device, an active data connection will be needed to use the Meraki Go App. This data connection can be either cellular (LTE) or over an existing WiFi network. 

Apple iOS Requirements

  • Devices running iOS 9.0 or higher

Android Requirements

  • Devices running Android 4.0 (Marshmallow) or higher

    • Android 6.0+ recommended



 

  • Was this article helpful?