Home > Switches > Port and VLAN Configuration > Recommended Configuration for Trunk Link to Non-Meraki Switches

Recommended Configuration for Trunk Link to Non-Meraki Switches

The default configuration on most enterprise switches will work out-of-box as vendors tend to use a default switch port config of "trunk all, with native vlan 1". It is important to note that if connecting a Meraki MS switch to another vendor's switch, the other end of the link must be identically configured. If this is not the case, the link may not operate as expected due to VLAN or Native VLAN mismatch. Common misconfigurations include:

  • switchport mode
  • trunk encapsulation type (must be dot1q)
  • native VLAN mismatch
  • allowed VLAN mismatch

 

In the following scenario, we have a Cisco Meraki access switch uplinked to an other (non-Cisco Meraki) switch. The network administrator has configured the Cisco Meraki uplink port as TRUNK Native VLAN1 with allowed vlans 1,10,20,30, and left the other side configured at defaults (trunk native vlan 1):

173dfbe2-b2c6-43c6-b725-b84c8c1f345b
 

In this scenario, users connected to the Meraki switch on VLAN 20 are not able establish a connection due to a non-similar configuration on the trunk links. The recommended configuration is to have both side of the trunk configured identically:

 

Cisco Meraki switch configuration example (assuming connection is on port 13)

Recommended Configurations

The following configuration examples outline how a non-Meraki peer switch's trunk link should be configured, to best operate with the example above.

Cisco Catalyst

Assuming connection is on port 1:

!
interface GigabitEthernet1/0/1
 switchport mode trunk
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,10,20,30
!

Dell PowerConnect

Note: Dell PowerConnect switches have LLDP disabled and Transparency enabled by default. In order to make use of the topology feature in Dashboard, LLDP must be enabled and Transparency must be disabled. The topology will not update immediately and may take some time and is not real-time.

 

Assuming connection is on port 1:

!
  interface ethernet 1/g1
    switchport mode general
    switchport general allowed vlan add 10,20,30 tagged 
 !

HP ProCurve

Assuming connection is on port 1:

switch1(config)# vlan 1
switch1(config)# vlan 10
switch1(config)# vlan 20
switch1(config)# vlan 30
switch1(vlan-1)# untagged 1
switch1(vlan-10)# tagged 1
switch1(vlan-20)# tagged 1
switch1(vlan-30)# tagged 1

Other Devices

Since Cisco Meraki VLAN tagging operates on the 802.1q tagging standard, any standard-compliant switch can be configured to operate in tandem with an MS switch. The best practice/examples outlined above should be used as a reference. For vendor-specific recommendations, refer to your switch vendor's documentation for 802.1q tagging and trunking.

You must to post a comment.
Last modified

Tags

Classifications

This page has no classifications.

Explore the Product

Click to Learn More

Article ID

ID: 1155

Explore Meraki

You can find out more about Cisco Meraki on our main site, including information on products, contacting sales and finding a vendor.

Explore Meraki

Contact Support

Most questions can be answered by reviewing our documentation, but if you need more help, Cisco Meraki Support is ready to work with you.

Open a Case

Ask the Community

In the Meraki Community, you can keep track of the latest announcements, find answers provided by fellow Meraki users and ask questions of your own.

Visit the Community